Uma solução para quem utiliza Ubuntu 16.04



 Recentemente foi lançado a mais nova versão LTS do Ubuntu; e com isso, muita gente está adotando e testando a nova versão do sistema.

 Alguns dias atrás um amigo me procurou por estar com um problema no Ubuntu 16.04. Ele ainda utiliza dual boot, mas quer deixar de utilizar Windows de vez. Porém, para que ele possa utilizar somente o Linux, ele ainda precisa resolver o problema do vídeo. Quando ele reproduzia os vídeos em tela cheia, ficava dando uns lags. Não é falta de uma boa configuração de hardware, pois essa é a configuração do seu notebook:
  • Dell com um processador core i5 de 1.8ghz
  • 8GB RAM
  • Placa de vídeo Nvidia GT 730M de 2GB
  • Dispositivo de armazenamento SSD.
 Com esse hardware, o Windows voa, mas no Ubuntu da lag ao assistir vídeos. A principio, sugeri que poderia ser que o Ubuntu estava utilizando um driver genérico, porém ele já havia instalado o driver proprietário e mesmo assim, permanecia dando lags nos vídeos do Youtube em tela cheia ou quando ia assistir algum filme no Netflix.

 Eu pedi para que ele verificasse se o módulo estava carregado utilizando o comanado "lsmod" (de repente, mesmo depois de instalado, o módulo poderia não estar carregado). Ele realizou o teste, copiou a saída do comando e me enviou. Eu por fim, filtrei a informação e aparentemente estava rodando, notando essas linhas:
nvidia_uvm 696320 0
nvidia_modeset 745472 3
nvidia 10076160 69 nvidia_modeset,nvidia_uvm
 Por fim, eu lhe perguntei: "Curiosidade. Já rodou outras distros neste notebook?"
 Ele me respondeu que já havia instalado o Linux Mint e o Debian. No Linux Mint ele não se recordava se isso acontecia, mas no Debian ele não chegou a instalar o driver de vídeo. Por fim ele me disse que iria testar outro HD que ele tem o Lubuntu instalado colocando ma mesma máquina.

Essa imagem foi fornecida pelo leitor Rodrigo Araújo
 Quando ele retornou, ele me informou que que com o Lubuntu funcionava normal. Concluí que o problema estava no MIR, o daemon servidor gráfico padrão do Ubuntu enquanto que no Lubuntu é utilizado o X.

 Expliquei sobre os servidores gráficos para ele e depois de um ou dois minutos retornou:
"Acredita que desativei a opção do driver (testado e proprietário) e ativei o X.org Xserver - Nouveau display driver de xserver-xorg-video-nouveua (open soucer) , e funcionou normal?"

Essa imagem também foi fornecida pelo leitor Rodrigo Araújo
 Por fim, agora ele está utilizando bem o Ubuntu. Juntos descobrimos como solucionar esse problema :-)

 Além de modelo, é bom técnico e está iniciando seu blog. Assim que estiver pronto Vou deixar o link do seu blog para que ele possa explicar melhor como realizou essa tarefa e quais os resultados disso.

Obs.: Não estou afirmando que o MIR é ruim (como muitos defensores fazem colocando defeito no Ubuntu e em tudo o que a Canonical faz). Simplesmente estamos compartilhando como solucionar um problema no ubuntu 16.04.

Sou analista (bilíngue) de microinformática, professor de inglês, tradutor e interprete.

 Sou também redator no blog Diolinux e um dos tradutores da distribuição Funtoo. Já fiz parte da distribuição IPFire por um tempo também, uma distribuição que gosto muito na parte de administrar o servidor por uma interface web.
 Possuo um manual chamado Caixa de Ferramentas do UNIX traduzido por mim e revisado por mais amigos que abrange tanto Linux (dentre algumas distribuições) quanto Solaris, BSDs, Mac OS X e em alguns momentos o Windows (devido a integração cliente servidor).
 Recentemente estou trabalhando em um manual de migração para Linux.

Compartilhe isso

Leia outros posts

Próximo post
« Próximo post
Post Anterior
Próximo Post »

4 comentários

Write comentários

Compre na imago brinquedos

Compre na imago brinquedos
Utilize o cupom de desconto TOCADOTUX e ecnomize 5% na sua compra