Uma solução para quem utiliza Ubuntu 16.04



 Recentemente foi lançado a mais nova versão LTS do Ubuntu; e com isso, muita gente está adotando e testando a nova versão do sistema.

 Alguns dias atrás um amigo me procurou por estar com um problema no Ubuntu 16.04. Ele ainda utiliza dual boot, mas quer deixar de utilizar Windows de vez. Porém, para que ele possa utilizar somente o Linux, ele ainda precisa resolver o problema do vídeo. Quando ele reproduzia os vídeos em tela cheia, ficava dando uns lags. Não é falta de uma boa configuração de hardware, pois essa é a configuração do seu notebook:
  • Dell com um processador core i5 de 1.8ghz
  • 8GB RAM
  • Placa de vídeo Nvidia GT 730M de 2GB
  • Dispositivo de armazenamento SSD.
 Com esse hardware, o Windows voa, mas no Ubuntu da lag ao assistir vídeos. A principio, sugeri que poderia ser que o Ubuntu estava utilizando um driver genérico, porém ele já havia instalado o driver proprietário e mesmo assim, permanecia dando lags nos vídeos do Youtube em tela cheia ou quando ia assistir algum filme no Netflix.

 Eu pedi para que ele verificasse se o módulo estava carregado utilizando o comanado "lsmod" (de repente, mesmo depois de instalado, o módulo poderia não estar carregado). Ele realizou o teste, copiou a saída do comando e me enviou. Eu por fim, filtrei a informação e aparentemente estava rodando, notando essas linhas:
nvidia_uvm 696320 0
nvidia_modeset 745472 3
nvidia 10076160 69 nvidia_modeset,nvidia_uvm
 Por fim, eu lhe perguntei: "Curiosidade. Já rodou outras distros neste notebook?"
 Ele me respondeu que já havia instalado o Linux Mint e o Debian. No Linux Mint ele não se recordava se isso acontecia, mas no Debian ele não chegou a instalar o driver de vídeo. Por fim ele me disse que iria testar outro HD que ele tem o Lubuntu instalado colocando ma mesma máquina.

Essa imagem foi fornecida pelo leitor Rodrigo Araújo
 Quando ele retornou, ele me informou que que com o Lubuntu funcionava normal. Concluí que o problema estava no MIR, o daemon servidor gráfico padrão do Ubuntu enquanto que no Lubuntu é utilizado o X.

 Expliquei sobre os servidores gráficos para ele e depois de um ou dois minutos retornou:
"Acredita que desativei a opção do driver (testado e proprietário) e ativei o X.org Xserver - Nouveau display driver de xserver-xorg-video-nouveua (open soucer) , e funcionou normal?"

Essa imagem também foi fornecida pelo leitor Rodrigo Araújo
 Por fim, agora ele está utilizando bem o Ubuntu. Juntos descobrimos como solucionar esse problema :-)

 Além de modelo, é bom técnico e está iniciando seu blog. Assim que estiver pronto Vou deixar o link do seu blog para que ele possa explicar melhor como realizou essa tarefa e quais os resultados disso.

Obs.: Não estou afirmando que o MIR é ruim (como muitos defensores fazem colocando defeito no Ubuntu e em tudo o que a Canonical faz). Simplesmente estamos compartilhando como solucionar um problema no ubuntu 16.04.

Analista (bilíngue) de sistemas, redator do blog Diolinuxtradutor da distribuição Funtoo e parte da distribuição IPFire, do manual chamado Caixa de Ferramentas do UNIX e do manual Zsh Lovers. Dono dos canais e blogs Toca do Tux e Resenha Nerd:

Compartilhe isso

Leia outros posts

Próximo post
« Próximo post
Post Anterior
Próximo Post »

4 comentários

Write comentários
15 de junho de 2016 16:13 delete

É muito bom saber desses problemas, sempre pode ocorrer. Quando alguém compartilha a experiencia, ele nos da uma luz sobre como pensar para solucionar. Obg por compartilhar, sempre estou tendo q ajudar um amigo, não sei porq mas o pc dele n roda as coisas direito nem a pau. Vlew

Reply
avatar
15 de junho de 2016 19:06 delete

Bom, nunca tive problema com o Unity, uso um Notebook LG a410, com um i5 de segunda geração, 4 GiB de RAM e uma poderosa Nvidia 310m (1GiB, 64bits kkk)Experimentei várias distros, e realmente o Unity é mais pesado, mas nada que chegou a esse ponto. Inclusive jogo CS:Go nesse notebook.

PS: Uma diferença boa em FPS no CS:GO usando o driver proprietário.

Reply
avatar
15 de junho de 2016 20:25 delete

Fala galera. Obrigado pelos comentário. Quero ressaltar que não estamos procurando colocar defeito na distro, mas deixar aqui uma solução que não é algo grave para caso mais alguém tenha o mesmo problema.

Reply
avatar
16 de junho de 2016 10:18 delete

Legal. Eu tive alguns problemas com o Ubuntu 16.04. A minha maquina ficou muito, muito lenta depois que eu formatei e instalei a versão. Retornei pra versão antiga e a maquina voltou a voar. Vou aguardar até o fim do ano quando eu creio que já existirá bastante correções.

Reply
avatar

Compre na imago brinquedos

Compre na imago brinquedos
Utilize o cupom de desconto TOCADOTUX e ecnomize 5% na sua compra